Magnum has the shakes...still

CustomMagnums.com is the premier Dodge Magnum Forum on the internet. Registered Users do not see the above ads.


Page 7 of 7 FirstFirst ... 567
Results 91 to 96 of 96




  1. #91
    Shaolin Ch'uan Fa Fireman2118's Avatar



    Array
    Join Date
    Mar 2008
    Location
    U.S.A.
    Posts
    18,841
    Quote: Originally Posted by stingrayj View Post
    Looking back at my pics, it does look like the oil is originating from the vent area. I was just concerned that it may be leaking to the point of having nothing left in it.

    Dropping more money into the "money pit on wheels" is really getting old. As much as I hate the idea of replacing the less than a month old brakes, it looks like I don't really have a choice.

    You shouldn't loose all the gear oil out of the vent.

    As far a replacing month old brakes. I feel for you, but you are correct in that you really "don't have a choice"




    '05 R/T

    PPP stage 3 big valve heads - Howards cam 219/227 .600/.575 112 LSA (108 ICL) - PAC 1518 springs - forged pushrods - 6.1 lifters - 6.1 oil pump - 6.1 timing set - Modern Muscle stage 1+ ported 6.1 manifold
    & 85mm throttle body - 6.1 fuel injectors - 6.1 fuel rails - 25% UDP - Jet 180 tstat - LMI 4" true CAI - MSD "Blaster" coils - 8.2mm Taylor wires - JBA headers - JBA high flow mids - Corsa catback - Diablosport Intune
    Paramount series 55, stage 1 transmission, "Dominator" 3000 stall tc & stage II valve body - Tranzformer shift kit - B&M Hi-Tek transmission cooler - 226mm Getrag 3.91 LSD - BC racing coilovers - Eibach front & rear sways
    Prothane & Whiteline bushing kit - BWoody endlinks - Razors Edge strut bar - Wilwood big brake kit by TCE - W6A 6 piston front calipers on 14.25" 2 piece GT rotors - Dynapro 4 piston rear calipers on 13" 2 piece GT rotors
    Trufiber Challenger A58 carbon fiber hood - Vossen VVS-CV3 & Nitto 420s - 22" x 9" w/265/35/22 & 22" x 10.5" w/295/30/22 - tuning by Ditos motors ---- Hemi Registry #943


    Reply With Quote
     
  2. Remove Advertisements
    CustomMagnums.com
    Advertisements
     

  3. #92
    Quando omni flunkus moritati. stingrayj's Avatar Array
    Join Date
    Sep 2008
    Location
    Hanover, PA
    Posts
    3,790
    Well, my saga continues...

    I have been taking it very, very easy on the brakes and did get in contact with Steve at R1. Per his recommendation I did a couple of brake bedding stops. There is still a vibration, but I'm not convinced that it is from warped rotors anymore. The vibration is "activated" by applying moderate to hard brake pressure. If you are easy on the brakes, there is practically no additional shaking from pressing the brake pedal. Also, if you drag out the final stop the brakes feel smooth. A warped rotor would pulse.

    The vibration that I have now is not really a vibration. It is more of a shake. It doesn't shake the wheel but you can feel it in the brake pedal if you press hard enough. It is not consistent at all in either its frequency or strength. There is also a knock coming from the right front wheel. The knock seems to happen when the wheel drops suddenly, like over a speed bump, or over washboard roads where the bumps come quick.

    So, here is what I am thinking now... It is either the front strut, sway bar end link, or upper ball joint. So, how do you go about properly testing each of these components for wear/damage? Also, will a strut, shock, and spring set from a (2007?) Charger Daytona fit on my '06 R/T?
    Reply With Quote
     
  4. #93
    Member lowendboy's Avatar Array
    Join Date
    Dec 2010
    Posts
    82
    you can rule out the end link. That can make noise but not likely to cause a vibration. Almost any other suspension component (bushing/balljoint) can cause vibration.
    I cant remember if you said that you replaced the tension struts or not. Those are very problematic and should be replaced with the latest OE version of the SRT tension strut.

    To check the upper ball joint, raise the front until the wheels are off the ground and support the car well. Grab the upper part of the wheel, or someone else, why the other one of you watch the ball joint for movement as the wheel is being forced in and out.

    you should inspect all joints and bushings. test tie rods by having someone grab the front and back of the wheel and try moving it left and right. the steering column should be locked. HAve someone look at the joints as that back and forth force is being applied.

    I do not believe the Charger springs and struts will work. The struts likely will. I had several Charger owners interested in the Eibach spring strut set I have and I have to inform them that Eibach has a different part number for the springs but the struts are the same part number.

    I hope this helps.
    Last edited by lowendboy; 03-03-2011 at 06:27 AM.
    Reply With Quote
     
  5. Remove Advertisements
    CustomMagnums.com
    Advertisements
     

  6. #94
    Member RTSolid's Avatar Array
    Join Date
    Mar 2011
    Posts
    79
    did you ever find a fix for this?
    Reply With Quote
     
  7. #95
    Senior Member RussianMagnum's Avatar Array
    Join Date
    Feb 2011
    Location
    Brooklyn NY
    Posts
    1,082
    Blog Entries
    1
    I don't know if it relAtive to your problem, but 10k ago I replace all the front suspension and put stock rims for the winter. After the winter bought Eibach pro kit and put rims back on. there the shakimg started, did allignment but my mechanic said that the rims are the problem. Went to tire shop did the balance and shaking reduced drastic. Mention that shaking would appear only between 50 - 65 mph other speeds there is no shaking. Now I need to fix 3 out of 4 rims, they bend on inside you would never tell unless you take ur tire off and run it on the machine.
    ProCharger, SRT4 injectors,3.91 Getrag, JBA shorties, Magnaflow Mids, Blastin Bobs 4" 7db, Inertia Spartan cam, tstat 180, SRT pulley, Eibach Pro kit, Brambo upgrade, slotted rotors, 6speed motor mounts, MSRT wheels with Vred tires, color matched eylids and lip, LED tail lights, Tint 20%
    11.9 sec @ 115mph
    431rwhp/428rwtq
    Reply With Quote
     
  8. #96
    Member allen1013's Avatar Array
    Join Date
    Dec 2006
    Location
    BX
    Posts
    299
    Quote: Originally Posted by stingrayj View Post
    Well, my saga continues...

    I have been taking it very, very easy on the brakes and did get in contact with Steve at R1. Per his recommendation I did a couple of brake bedding stops. There is still a vibration, but I'm not convinced that it is from warped rotors anymore. The vibration is "activated" by applying moderate to hard brake pressure. If you are easy on the brakes, there is practically no additional shaking from pressing the brake pedal. Also, if you drag out the final stop the brakes feel smooth. A warped rotor would pulse.

    The vibration that I have now is not really a vibration. It is more of a shake. It doesn't shake the wheel but you can feel it in the brake pedal if you press hard enough. It is not consistent at all in either its frequency or strength. There is also a knock coming from the right front wheel. The knock seems to happen when the wheel drops suddenly, like over a speed bump, or over washboard roads where the bumps come quick.

    So, here is what I am thinking now... It is either the front strut, sway bar end link, or upper ball joint. So, how do you go about properly testing each of these components for wear/damage? Also, will a strut, shock, and spring set from a (2007?) Charger Daytona fit on my '06 R/T?
    Hey stingrayj, i know some years have passed on this issue but did you ever find out what was causing the shakes? I'm going through the same exact symptoms and can't pin point what's wrong.
    Reply With Quote
     
Page 7 of 7 FirstFirst ... 567

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •