Custom Dodge Magnum Forums banner

transmission problem

  1. switched the battery terminals and busted fuses :/

    Submit Articles Here
    I wanted to replace my battery so I bought a optima red top. Sold the old battery and had to switch them out in the in the parking lot. Was in a bit of a rush so I figured I put the positive in the right place but I was wrong. Lol its a damn red top so the negative and positive were labeled...
  2. I need some help on this one...

    General Magnum Discussion
    Hey Guys, So thanks for all the help in the past, and now unfortunately im in need of some more. So heres my issue. I go to start my car, no problems, put it in reverse, normal operation. Shift into drive, and here is where it starts. Well, i guess i should say, i have a 2006 3.5L AWD, i love...
  3. Some UNEXPECTED new work

    General Magnum Discussion
    Well, I guess it isn't totally unexpected, but for the last little while i have been having some Transmissions problems. After i would pull up to a set of lights or stop sign, when i would pull away, it was like a loss of power, or the transmission going into limp mode, well after this happening...
  4. 42RLE (4-Speed) Symptom & Solution

    V6's
    So sometime about 6 months ago I started chasing a ghost of a problem with my car. At this time I had been going through a lot of changes with the tune trying to resolve some issues and thats when the problem started popping up. Oddly enough my friend Nate (BritishNate) was in almost the...
Top