Custom Dodge Magnum Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I have a 08 Magnum SE owed it for 2 years now. It started making a Clunking noise over every bump. Did a little reading and people were replaceing the sway bar bushings, so replaced, they were cheap $14 for both, still making the noise. Read a little bit more and people were replacing the tension struts. Well inspected mine looked wore out and replaced, still same clunking NOISE!!!! Everything else looks to be in good shape. I don't want to keep throwing money at parts that won't FIX my problem. Can anyone help???
 

·
CMOM FOR DEC 08
Joined
·
26,575 Posts
Two of mine have a slight clunking noise too and ONE of them just replaced tie rod ends and stablizer bars so I have NO idea where the noise is coming from. Had a friend tell me he thought it was the "inner tie rod ends" ~ who knows!
 

·
Registered
Joined
·
562 Posts
You probably ought take it down and have it inspected by an alignment/ suspension shop even if you can do the work yourself. Could be as Jim stated the inner/outer tie rods. I am currently in the same chase as you are. Quite annoying even though the car steers fine.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
Yea, it is really annoying. Everytime someone gets in my car and we start rolling they are like what the Hell is that noise and I jus tell them Im working on trying to fix it.....
 

·
Registered
Joined
·
562 Posts
Agreed, I'm at the point of willing to pay someone just to inspect it and find it so I can get the right part. I have the sway bar bushings sitting on the floor board of my car right now waiting install. Was hoping this would take care of it. So far Besides springs/dampers to lower the car, I have had to get 2 new tension struts, sway bar end links, Strut mounts cuz my dumb azz stripped out the threads on 2 and still haven't gotten it. This morning I just ordered 2 new lower control arms as mine are worn to hell. Firguring I will need 2 new lower ball joints as well, I know the one on the left side is worn out. Figure after that I will just go ahead and do the upper control arms and tie rods to complete the front end rebuild.
 

·
Registered
Joined
·
172 Posts
I've got the same problem replaced my tire rods, had an alignment an still, this Thursday I'm having them look at the inner tire rods, We'll see how this goes
 

·
Registered
Joined
·
44 Posts
I just went thru this same problem on my 05 SE, $1500.00 later noise is gone. Very expensive, but I have a new front suspension now. Good luck
 

·
MR 3 FIFTEEN
Joined
·
12,413 Posts
You probably ought take it down and have it inspected by an alignment/ suspension shop even if you can do the work yourself.
Sounds like good advice to me. Let them figure it out, then replace the part yourself.
 

·
CMOM FOR DEC 08
Joined
·
26,575 Posts
I've got the same problem replaced my tire rods, had an alignment an still, this Thursday I'm having them look at the inner tire rods, We'll see how this goes
ON my black R/T is the one I had the outter tie rod ends and stablizer bars done and still slight noise and was told by a different person that it's the inner tie rod ends and he had me hold on to the inner tie rod ends and he shook the steering wheel and I could feel the rattling in there! NOW it's the same thing on BLUE! Geesh!
 

·
Premium Member
Joined
·
18,999 Posts
I have to agree with Frostbit... take it to a GOOD alignment shop and see what they say......Tie Rod Ends or a ball joint.. how many miles do you have on her?
 

·
Registered
Joined
·
63 Posts
Yea a good alignment might help. i replaced the sway bar bushings and radial arms and tie rod ends on my magnum last year...
 

·
Registered
Joined
·
17 Posts
Could be the struts also since you have replaced all the normal problems! How many miles do you have on the car? the mounts could be loose or the strut could be shit! for me thats what it was I had 98k and I relpaced Both inner/outter tie rods both tension sturts,Struts, both swaybar links and bushings and just got done balljoints and now I have no noise and an almost new suspension thanks to the good people of this site and Moog! lol
 

·
Registered
Joined
·
1,421 Posts
I have the same clunking noise coming from the front. I have had nothing but Dodge vehicles for the last 15 years. Every Dodge that I have ever had looses its tie rod links at about 5 years. It's an easy fix but i wouldn't call it a cheap one.
 

·
Registered
Joined
·
458 Posts
More than likely its the outer tie rod ends. Check that out. I replaced them myself. No more clunking noise. Bought the parts from my local NAPA store.
 
1 - 16 of 16 Posts
Top