Custom Dodge Magnum Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello all. I have a 2006 Magnum R/T AWD. A year ago I put some 22 inch Martin Bros. 939 Sharktooth rims on her and have been getting the shake upon acceleration ever since. I've had the wheels checked for bending, tires balanced about 100 times, Road force balancing, rotation, and even replaced a loose outer tie rod. Nothing seems to help. Had hub rings replaced. Nothing changed. I don't know what else to do. The specs of the rims are 22"x9.5. Is there anything else I can do, or am I just gonna have to let the wheels go?
 

Attachments

·
Registered
Joined
·
4,227 Posts
If you still have the stock wheels I would suggest putting those on just to see if you still have the same shake. This atleast would eliminant the question of, "Is it the wheel or the car?"
 

·
Registered
Joined
·
1,788 Posts
I would check the tension Struts for wear.. Just the weight from bigger wheels can make even the most minor problems seem worse..

Sent from my HTC EVO on tapatalk
 

·
Registered
Joined
·
112 Posts
^^^^^ what they said^^^^^
The info you provided would lead me to say it's the car and not the rims/tires (if they've been checked etc). Unless it's a bad tire.... But if theyve been rotated the vibration would occur wherever that tire is. Being that is Magnum, I bet you have more front end work to do, maybe look at the brakes as well.
My 0.2$
 

·
Shaolin Ch'uan Fa
Joined
·
18,841 Posts
You need to have the inner tie rods and outer tie rod ends checked along with the upper and lower ball joints. While you're checking the inner tie rods, inspect the steering rack. Check the tension strut bushings for cracks.
 

·
MR 3 FIFTEEN
Joined
·
12,414 Posts
I agree with all of the statements above. I had to replace rotors, ball joints, tension struts and tie rod ends before the shaking finally stopped. I started havin problems 2 months after I put my 22 on, but I'm sure these components were wearing before I put the rims on. She's solid now, rides like a tank.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Problem solved

Well everyone. The problem turned out to be THE TRANSMISSION. Torque Converter was destroyed. Replacing the converter is a temporary fix, but the only thing that will fix it is to replace the ENTIRE transmission. Still shakes a bit after a cold start, but not long. Thanks for all the input.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
Shake upon acceleration???

Take your car to any transmission repair shop and have them check your TORQUE CONVERTER. I guarantee that's your problem.
 
1 - 9 of 9 Posts
Top