Custom Dodge Magnum Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi guys,
I got a problem with my -05 Magnum, about a few weeks ago my AC Blower broke down, so i checked the fuses, no damage there so i measured the voltage to the blower motor and i got something over 12V, I thought i must be the motor that´s broke so ordered new one and istalled but NO it doesn´t work

And the funny thing is when i turn on the blower, maybe 5seconds after, my Airbag lights turns on, and when the blower is off the airbag light goes away

any ideas what it could be?
AC Control panel ?

(sorry for my poor english ;P)
//Tommi
 

·
Who Dat !!!
Joined
·
1,406 Posts
I just had a issue with mine. The blower stopped working when I put it on the second to highest setting. About two weeks later my control shorted out. I have a 05 as well. If you change your climate controls you may have the same issue I ran into. They changed the plug on the climate control for the fan control part. So you can order a newer control but you need to order a harness they have made as well for that one plug. Just a heads up.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5 (Edited)
Can you define, "broke down". And have you done any electrical mods lately?
No electrical mods is done lately, it just happend one morning a few weeks ago, when i was driving to work and i would put the blower on but nothing happened, then the "PLING" noise came and the Airbag light was on, and because it didn´t blew anything so i turned the blower off and a few seconds later the airbag light went off aswell

This is the "blower control panel" I have
http://bilder.lagabasen.se/delar/1074/1074709582vy1.jpg

//Tommi
 

·
Registered
Joined
·
235 Posts
Thats weird. Whats weirder is that mine is "clunking" now when I turn on my AC. Wish I could help you bro, now I gotta figure out mine. lol

Its alllllways something.....
 
1 - 6 of 6 Posts
Top