Custom Dodge Magnum Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I got in my car the other morning and my instrument cluster lights on my dash dont work anymore,the temp,and the gear indicator lights up,and all the gauges still work just no lighting..anyone have any idea of what this could be?:eek:mfg:
 

·
CMOM FOR DEC 08
Joined
·
26,574 Posts
My guess would be just a fuse ~ Check owners magnum for which fuse!
 

·
"INSTITUTIONALIZED"
Joined
·
5,718 Posts
I had the same issue on my SNOWMOBILE (05 SXT) n luckily for me-I still had warranty on it n it got replaced.They did not say wut wuz the actual prob other than the whole cluster had to B replaced.That wuz good enuff for me till I got my car back and they added the wrong mileage by 3000 more.They ended up takin that 1 out again n replacin it wit another 1 wit the correct mileage.If U dod get it replaced-B aware of yer mileage so this wont happen to U!!!!!

I tryd fixing it myself by taking apart the cluster n got it to light up but went off again shortly.If U dnt wanna spend the $$$$$ for a new 1-get custom wit it n run sum LEDz in there-I have seen em go uzed for about $60 on up on ebay-juzt type in dodge magnum cluster-juzt make sure U get the same part #-hope this helpz!!!!!
 

·
where's my airbrush??
Joined
·
14,795 Posts
i don't think its a fuse, its like the a/c control cluster, when the lights go out the unit has to be replaced.

I have an 06 unit that reads 39K for sale, you could have the miles reprogrammed at the dealer to your correct mileage.
 

·
Registered
Joined
·
4 Posts
There's a video on youtube:
Repairing an Instrument Cluster Backlight with the ELD-M on a 2005 Dodge Magnum

This also works on the Charger, Sebring, 300C, and Challenger.
 
1 - 6 of 6 Posts
Top