Custom Dodge Magnum Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
336 Posts
Discussion Starter #1
I think I bought a bad batter...but not certain. Can you guys and girls give me your thoughts?

Turn key = Click, Click, Click, Click & so on...
Buy a new battery, install it = Click, Click, Click...but lights come on, a/c fan comes on etc.
Jumps start it with my other car (my newly acquired 2008 Silverado Crew Cab Z71!!)...anyway, Magnum starts immediately.

Let it run ~15 minutes, and notice the interior lights dimming, and then brightening, constantly throughout the entire ~15 minutes.
Turn it off, turn the key = Click, Click, Click...but the lights work.

The clicking is coming from the back (where the battery is), not from under the hood - i.e. alternator/starter.

Whatcha think? Of course I could just take it to get tested, but my OCD doesn't play well with waiting...so wanted to get some of your expertise...if not the battery, then I'm thinking the alternator.[?]

Any comments would be very much appreciated. Thank you.
 

·
Premium Member
Joined
·
18,840 Posts
Sounds like a battery to me.
 

·
MR 3 FIFTEEN
Joined
·
12,413 Posts
Usually, the starter will give warning when it's goin bad. Really hard starts, grinding, etc. If you haven't experienced any symptoms, it's prolly not that.
 

·
Registered
Joined
·
1,333 Posts
Just press and hold your 2 inner bottom buttons on the steering wheel till you see it to into diagnostic mode, scroll thru till you see voltage, while running should be close to 14 v range. If it is it's not your alt.
 

·
CMOM FOR DEC 08
Joined
·
26,575 Posts
I'm thinking battery as well.
 
1 - 6 of 6 Posts
Top