Custom Dodge Magnum Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
101 Posts
Discussion Starter #1
have any of you guys installed jba catback ,, i installed mine and i have a vibration i don't know were it is coming from i have checked everything i know i am thinking i might have a bad muffler or something loose ,the vibration only comes ona hard pull kinda like a vibration on glass i almost wish i didn't install them and am ready to go back to stock ,, has anyone else had any trouble ????
 

·
VinylDecals.com
Joined
·
1,757 Posts
lilrobo said:
does the distance matter of the tips from the rear valance that might be the trouble
It depends on how loose your pipes are. Do you have any clue as to where it is rattling? Is it in the very back or in the middle of the car? Is it only at idle or WOT?
 

·
Registered
Joined
·
101 Posts
Discussion Starter #4
it happens right befor it changes gear ,, i had my son try to listen in the rear part with the gate open and everything removed totaly,,tire and all i think its coming from the muffler, he tryed to hold the tips while we were driving no luck i don't know ,, it does it mainley under a load ,,
 

·
VinylDecals.com
Joined
·
1,757 Posts
Is it a rattle? Have you checked all the clearances under the car to make sure nothing is rubbing the underside or close to the body and make sure all of the exhaust hangers are properly mounted? Who installed it? If a shop did it, you may want to take it back to have them check it out. What happens if you just rev it up in park or neutral?
 

·
Registered
Joined
·
101 Posts
Discussion Starter #6
i have check the clearances everything is fine there i did the install my self i was very simple really i have talked to jba and they are oing to send me 2 more mufflers i hope thet fixes it
 

·
VinylDecals.com
Joined
·
1,757 Posts
If it happens right before you change gears, it may be the mufflers. Maybe the change in backpressure is rattling something inside the mufflers. Hope the new muffs solve the problem.
 

·
Registered
Joined
·
11 Posts
Check to make sure your pipes aren't flexing so much that they are vibrating against the cross member!
 

·
Registered
Joined
·
101 Posts
Discussion Starter #9
i talked with hhpracing they are great the best to deal with they are going to hook me up witha set of new mufflers if you need anything give they a call
 

·
Registered
Joined
·
27 Posts
hi i had the same trouble with my magnaflow cat backs ,it would vibrate between gears or when the car is loafing and i gave it a slite acceleration it looked all clear under the car but at the end of the chrome pipe it had a quarter inch clearance it wasnt enough under load it cust touched the back circle where the chrome tips came out ,i loosened the rear pipe and twisted it another quarter inch and that was it , when you change from the factory exhaust the back pressure does different things its trial and error , joe
 

·
Registered
Joined
·
101 Posts
Discussion Starter #11
thanks joe
when i install the new mufflers i will check the that . i got the new ones in yesterday i open them up and there was a slite rattal like a small small bit in there i hope that don't cause a problem
 
1 - 13 of 13 Posts
Top