Custom Dodge Magnum Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,593 Posts
Discussion Starter #1
I pulled my air filter yesterday to clean it before I went to the shop for my rack and when I removed it I had a LOT of trouble getting it off the intake tube. Felt like it was fused to the coupler. Cleaned it like I always have and let it air dry over night. Got it reoiled this morning and when I went to install it I could hardly get the filter onto the intake tube. It honestly looks and feels like the inner diameter of the cone filter has reduced by about 1/8" and it is SUPER tight. Does not go on all the way any more.

I found this very odd and googled it. Apparently if the rubber in the filter is exposed to high heat it can shrink just as I have seen. The odd part is that the ONLY source if heat it has been exposed to is from under the hood and NOTHING else there has been affected nor has it ever overheated.

Going to email them about a warranty replacement but find this very odd. Has ANYONE here had this similar issue with any K&N filter element?
 

·
CMOM FOR DEC 08
Joined
·
26,575 Posts
Hmmm, never had any problem like that with mine.
 

·
Registered
Joined
·
979 Posts
I had a similar issue with a k&n filter on my old school. It has a warranty on it, I brought it back to O'Reilly's and they replaced it.
 

·
Shaolin Ch'uan Fa
Joined
·
18,840 Posts
I've noticed what you're referring to with K & N but I've always been able to make it fit the tube. I would take it back if you can't get it to work. I won't buy K & N filters anymore.

I would suggest "Green USA" or S & B filters. I've never had an issue with either.

http://www.greenfilterusa.com/

http://www.sbfilters.com/
 

·
Registered
Joined
·
1,593 Posts
Discussion Starter #5
After a LOT of effort I managed to get the filter onto the adapter for the intake tube. But it is a VERY tight fit now. The only good thing is that I can still clean it if I leave it on the adapter. Definitely going to try for a warranty replacement but I am most definitely going to tell them how displeased I am. Seems VERY odd that something that is exposed to under hood heat should be affected in this way. Sounds to me like they need to rethink the compound they use if this is as common a problem as it looked when I searched on it.

Thanks for the suggestions fireman...I will def look into those.
 

·
Registered
Joined
·
1 Posts
I pulled my air filter yesterday to clean it before I went to the shop for my rack and when I removed it I had a LOT of trouble getting it off the intake tube. Felt like it was fused to the coupler. Cleaned it like I always have and let it air dry over night. Got it reoiled this morning and when I went to install it I could hardly get the filter onto the intake tube. It honestly looks and feels like the inner diameter of the cone filter has reduced by about 1/8" and it is SUPER tight. Does not go on all the way any more.

I found this very odd and googled it. Apparently if the rubber in the filter is exposed to high heat it can shrink just as I have seen. The odd part is that the ONLY source if heat it has been exposed to is from under the hood and NOTHING else there has been affected nor has it ever overheated.

Going to email them about a warranty replacement but find this very odd. Has ANYONE here had this similar issue with any K&N filter element?
After a LOT of effort I managed to get the filter onto the adapter for the intake tube. But it is a VERY tight fit now. The only good thing is that I can still clean it if I leave it on the adapter. Definitely going to try for a warranty replacement but I am most definitely going to tell them how displeased I am. Seems VERY odd that something that is exposed to under hood heat should be affected in this way. Sounds to me like they need to rethink the compound they use if this is as common a problem as it looked when I searched on it.

Thanks for the suggestions fireman...I will def look into those.

I just had the EXACT same thing happen! I lost about 1/4"! Now I need to buy a new filter - this one is done! Boooo......
 
1 - 6 of 6 Posts
Top