Custom Dodge Magnum Forums banner
1 - 9 of 9 Posts

·
Double-U Tee Eff
Joined
·
3,065 Posts
Discussion Starter · #1 ·
Okay. Yesterday, it did it again. I can count the number of times, within the 3 years I've had my Magnum, on one hand; either 3 or 4 times; that either while driving at or below 40 mph, I hear a ding and my car shuts off. It did it again and my oil pressure light came on. No biggie right? cuz everytime this has happened, it's just a matter of restarting the car again. While driving at 40 mph, it turns off, I just put it in NEUTRAL and start it again; keep on trekkin'. Anybody ever have this happen to them?
 

·
Registered
Joined
·
52 Posts
I had a similar thing happen on a brand X car. Turned out to be the oil pressure switch. Apparently, if the oil pressure drops below a certain level, the switch opens and cuts off electricity to the fuel pump. I changed the pressure switch and never had any trouble again. Actually, my headers over heated it. I hope this helps.
 

·
Double-U Tee Eff
Joined
·
3,065 Posts
Discussion Starter · #5 ·
I had a similar thing happen on a brand X car. Turned out to be the oil pressure switch. Apparently, if the oil pressure drops below a certain level, the switch opens and cuts off electricity to the fuel pump. I changed the pressure switch and never had any trouble again. Actually, my headers over heated it. I hope this helps.
it's a good safeguard if the pressure drops too low, but I'm gonna have to check it out

thanks! :)
 

·
Premium Member
Joined
·
18,840 Posts
Doesn't sound right to me. A safety feature wouldn't shut the car off while still moving. Limp mode maybe, but not off, that's not exactly safe. Can you say power steering, power brakes. IMHO !
I'm thinking you may have some sort of electrical problem.
 

·
Registered
Joined
·
42 Posts
I had this happen to me once. December 21 07 I drove from Austin, TX to Las Cruces, NM in a straight shot on my way to CA. I pulled into a hotel around 1am and as Im cruising into the parking lot (20 mph) car shuts off and oil light comes on. I restart the car and had no further problems the rest of the trip. I got an oil change when I made it to CA and had no problems since.

Now I will add that although this isn't related every now and then I hear this noise coming from the back of the mag, almost like someone is shaking a piece of foil (no joke). It usually happens on a quick acceleration I've checked everything and all my connections are good.
 

·
Registered
Joined
·
11 Posts
I had this happen to me once. December 21 07 I drove from Austin, TX to Las Cruces, NM in a straight shot on my way to CA. I pulled into a hotel around 1am and as Im cruising into the parking lot (20 mph) car shuts off and oil light comes on. I restart the car and had no further problems the rest of the trip. I got an oil change when I made it to CA and had no problems since.

Now I will add that although this isn't related every now and then I hear this noise coming from the back of the mag, almost like someone is shaking a piece of foil (no joke). It usually happens on a quick acceleration I've checked everything and all my connections are good.

Did you ever find what was making the sound I have the same problem and my car electronics shuts off and turns back on right away but the stereo programming stays
 
1 - 9 of 9 Posts
Top